SchemaTheek
 
Home Nieuws Forum Schema's Artikelen Magazine Downloads Links Shops Zoeken
 
Controle Paneel
Gebruikersnaam
Wachtwoord
  Onthoud mij
» Wachtwoord?
» Registreren
Site info
» Het Team
» Contact
» FAQ
» Leden
» Upload Archief
Stats
Totaal online: 3
3 gasten
0 leden:
Forum > Digitaal > 74HC165
« 1 [2]
pascalbianca
Lid
Berichten: 1437
Gepost op maandag 17 Februari 2014 16:24:12 QuoteWijzig

Wow wat een scoopje kan doen, heb het gevonden, alleen mijn ledje gaat heel h??l erg zwak aan/uit.
Door de scoop ben ik erachter gekomen dat het wel werkt.

Code
 Symbol PCF8574A_ADDR = %01110001 ;56
 
 
start:

 DelayMS 500
Cls
BStart
Print At 3,1,"PCF8574 schrijf"
HBusOut PCF8574A_ADDR, [%11111111]
BStop

DelayMS 1000

BStart
Print At 3,1,"PCF8574 lees"
HBusOut PCF8574A_ADDR, [%00000000]
BStop
GoTo start



Iemand een idee hoe ik dat ledje feller kan laten branden?

[update]
BStart en BStop weg gehaald, deze hebben in de HBusOUt/In totaal geen enkele werking.
 
[Bericht gewijzigd door pascalbianca op Maandag 17 Februari 2014 16:47:48]


http://pascalbianca.blogspot.nl/
Henk (NL)
Lid
Berichten: 263
Gepost op maandag 17 Februari 2014 18:52:59 QuoteWijzig

Maak beide DelayMS eens gelijk.

Toch handig he, effe meten met een scoop.
Later ga je wel doorsparen voor 'n duurdere,
zodra je er achter komt, dat in een aantal gevallen 'n goede scoop belangrijk is.

pascalbianca
Lid
Berichten: 1437
Gepost op maandag 17 Februari 2014 20:29:49 QuoteWijzig

Die heb ik, maar moet hem nog leren gebruiken

Ik heb beide delayms nu hetzelfde maar geen effect.
Nu was ik mij die link van jou aan het bekijken en daar zetten ze op 1 poort 5V en 1 met Ground, zou je niet dan 1 poort als uitgang moeten waar de led op zit en 1 met ingang met die 5V ? tis maar een redenering van me.


http://pascalbianca.blogspot.nl/
Henk (NL)
Lid
Berichten: 263
Gepost op maandag 17 Februari 2014 21:45:31 QuoteWijzig


Quote
Ik heb beide delayms nu hetzelfde maar geen effect.


Daar was ik benieuwd naar, want ik kom met de I2C clock met hetzelfde effect tegen, de pulsen niet symetrisch, oftewel 50%-50%.
Dit effect heb ik toegelicht in de PS/2 topic.
Tevens op Pic Basic forum.
Blijkbaar gaat de Compiler nog niet goed om met die (clock)signalen.
Zowel I2C als HBusOut.


Quote
Nu was ik mij die link van jou aan het bekijken en daar zetten ze op 1 poort 5V en 1 met Ground, zou je niet dan 1 poort als uitgang moeten waar de led op zit en 1 met ingang met die 5V ? tis maar een redenering van me.


Watblief
Ik het 3x gelezen maar nee, ik weet niet wat je nou bedoeld...
 
[Bericht gewijzigd door Henk (NL) op Maandag 17 Februari 2014 21:46:38]

pascalbianca
Lid
Berichten: 1437
Gepost op maandag 17 Februari 2014 22:15:19 QuoteWijzig

Ik zal het proberen uit te leggen wat ik bedoel , maar om iets nog even te testen heb ik nog een vraagje.

Ze zeggen dat 01000000 hetzelfde is 0?40 kun je dat ergens berekenen of waar kun je dat uithalen want stel je hebt een ander adres hoe kun je dat dan omzetten, tenminste dat zeggen ze hier.:

Quote
Since we tied the address pins to ground, the write address is 01000000 (0?40).


http://pascalbianca.blogspot.nl/
pascalbianca
Lid
Berichten: 1437
Gepost op maandag 17 Februari 2014 22:38:05 QuoteWijzig

Lees nu dat het iets met waarde te maken had , stukje bij input.
Dus snap nu eigenlijk niet waarom die led niet normaal brand , maar erg zwak.


http://pascalbianca.blogspot.nl/
pascalbianca
Lid
Berichten: 1437
Gepost op maandag 17 Februari 2014 22:48:01 QuoteWijzig

SOLVED!
De led brand normaal maar wel met lang zoeken kwam ik dit tegen en inderdaad het klopt betreffende het aandrijven van een led.


Quote
There?s a hidden gotcha with this part which I just encountered (unfortunately after having PC boards fabricated). The outputs can?t actually source much current. The statement on the data sheet that says ?latched outputs with high-current drive capability for directly driving leds? actually refers to inverse-logic current sinking, not sourcing. If you look at the current ratings on the Absolute Maximum Ratings table you?ll see that they seem to be ?backwards? if you?re thinking in terms of a positive-logic current-sourcing configuration.

The schematic for this article shows a current-sourcing configuration. Personally I can?t get this chip to drive even a single LED as shown in this schematic, but it works fine in a current-sink configuration.


http://pascalbianca.blogspot.nl/
pascalbianca
Lid
Berichten: 1437
Gepost op dinsdag 18 Februari 2014 17:34:50 QuoteWijzig

De input werking heb ik ook gevonden


http://pascalbianca.blogspot.nl/
« 1 [2]

Active Topics

» Whirlpool kookplaat
» 24 volt motor vertrage...
» Show je mini projecten
» Purer 8.3se
» MULTIMETERS geven alle...
» Werkplaatsinrichting
» 2022
» De tuin.
» li-ion diepontlaadbev...
» Subaru Outback 2016

» Meer actieve topics

Advertenties

ElektronicaStynus

© 2004-2022 SchemaTheek
Laadtijd: 0.3582 sec.